Interface-Hero-Background

SAP NetWeaver ODBC Driver

SAPNetWeaver

Select your platform

Table of Contents:

    Overview

    Progress DataDirect’s ODBC Driver for SAP NetWeaver offers a high-performing, secure and reliable connectivity solution for ODBC applications to access SAP S/4HANA Cloud data. Our ODBC driver can be easily used with SQL across all platforms - Unix / Linux, AIX, Solaris, Windows and HP-UX. Enjoy real-time analytics, reporting and business intelligence (BI) capabilities with your favorite tools such as Tableau, Power BI, Qlik, Excel, Cognos, Informatica, SAS, Board, MicroStrategy, SSIS, Oracle OBIEE and more.

    • Automatically normalizes the JSON response data from the API and transforms it to a relational data model
    • Speed up processes and automation without manual data workflows or custom coding
    • Engineered for enterprise-grade security standards

    Features

    Fast

    Superfast data loading and extraction that reduces the time and cost of running enterprise infrastructures 

    Versatile

    Supported on every major platform and certified to work with leading applications such as Power BI, Tableau, Informatica, Cognos, SAS, Business Objects and more 

    Secure

    Engineered for enterprise-grade security standards.

    SQL & Pushdown Capabilities

    The Progress DataDirect Connector for SAP S/4HANA Cloud is fully SQL-92 compliant.

    Technical Specifications

    Progress DataDirect for ODBC for SAP S/4HANA
    Version 8.0.1
    (32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

    ODBC Version Support

    • Compatible with ODBC 3.8 applications

    Version Support

    • SAP S/4HANA Cloud 2005 and higher
    • SAP BW/4HANA 2.0
    • SAP ODATA V2 Services from SAP NetWeaver Gateway

    Operating System Support

    Linux x86 (32- and 64-bit for AMD and Intel processors)

    • Debian Linux x86, version 12.0 and higher
    • Oracle Linux x86, version 6.0, 7.0, 8.0, 9.0 and higher
    • Red Hat Enterprise Linux x86, version 6.0, 7.0, 8.0, 9.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 12, 15 and higher
    • Ubuntu Linux x86, version 14.04, 16.04, 18.04, 20.04, 22.04 and higher

    Windows (32- and 64-bit)

    • Windows (x86), version 10, 11 and higher
    • Windows Server (x86), version 2012, 2016, 2019, 2022 and higher

    Driver/Client Software Requirements

    • A Java Virtual Machine that is Java SE 8 or higher, including Oracle JDK, OpenJDK, and IBM SDK (Java) distributions.

    Connect any application to any data source anywhere

    Explore all DataDirect Connectors

    A product specialist will be glad to get in touch with you

    Contact Us