Supported Configurations

Select any data source from the list below to view the supported configurations.



Amazon Redshift

ODBC

Progress DataDirect for ODBC for Amazon Redshift Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Supported Versions
  • Amazon Web Services API (Version 2012-12-01 and later)
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect for JDBC for Amazon Redshift Driver
Version 5.1.4

Supported Versions
  • Amazon Web Services API (Version 2012-12-01 and later)
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Apache Cassandra

ODBC

Progress DataDirect for ODBC for Apache Cassandra Driver
Preview Version

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Supported Versions
  • Apache Cassandra, version 1.2 and higher
Operating System Support
Windows (32- and 64-bit)
  • Windows (x86), version 7 and higher
  • Windows Server (x86), version 2003 and higher
  • Windows Vista (x86)
  • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 6 or higher

JDBC

Progress DataDirect for JDBC for Apache Cassandra Driver
Version 6.0.0

Protocol Support
  • Apache Cassandra, version 2.0 and higher
Supported Versions
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 6 or higher


Apache Hive

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC for Apache Hive Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Protocol Support
  • HiveServer 1 and HiveServer2
Hive Version Support

Supports Apache Hive version 0.7.1 and higher against the following distributions:

  • Amazon Elastic MapReduce (Amazon EMR), version 2.1.4 and higher
  • Apache Hadoop Hive
  • Cloudera's Distribution Including Apache Hadoop (CDH), version CDH3 update 4 and higher
  • Hortonworks Data Platform (HDP), HDP version 1.3 and higher
  • IBM BigInsights, version 3.0 and higher
  • MapR Distribution for Apache Hadoop, version 1.2 and higher
  • Pivotal HD Enterprise (PHD), version 2.0.1 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i Version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), Version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect XE for JDBC Apache Hive Driver
Version 5.1.4

Protocol Support
  • HiveServer 1 and HiveServer2
Hive Version Support

Supports Apache Hive version 0.8.0 and higher against the following distributions:

  • Amazon Elastic MapReduce (Amazon EMR), 2.1.4 and higher
  • Apache Hadoop Hive
  • Cloudera's Distribution Including Apache Hadoop (CDH), version CDH3 update 4 and higher
  • Hortonworks Data Platform (HDP), HDP version 1.3 and higher
  • IBM BigInsights, version 3.0 and higher
  • MapR Distribution for Apache Hadoop, version 1.2 and higher
  • Pivotal HD Enterprise (PHD), version 2.0.1 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Apache Spark SQL

ODBC

Progress DataDirect for ODBC for Apache Spark SQL Wire Protocol Driver
Version 8.0.2

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Supported Versions
  • Apache Spark SQL, version 1.2 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), 11i version 2.0 (B.11.23) and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect for JDBC Apache Spark SQL Driver
Version 6.0.1

Protocol Support
  • Apache Spark SQL, version 1.2 and higher
Supported Versions
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 6 or higher


Clipper

ODBC

Progress DataDirect Connect for ODBC dBase Driver
Version 7.1.6

(32-bit drivers are available for all supported databases and platforms.)

Database Support
  • Clipper
Operating System Support
  • AIX (32-bit)
    • AIX, version 5.3 and higher
  • HP (32-bit)
    • HP-UX PA-RISC, version 11 and higher
  • Linux x86 (32-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements


Cloudera Impala

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Impala Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Cloudera Impala 1.0 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect XE for JDBC Impala Driver
Version 5.1.4

Database Support
  • Cloudera Impala 1.3 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Database.com

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Salesforce Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Salesforce API
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 5 or higher

JDBC

Progress DataDirect Connect XE for JDBC Salesforce Driver
Version 5.1.4

Supported Versions
  • Salesforce API
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


DB2

ODBC

Progress DataDirect Connect and Connect64 for ODBC DB2 Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • DB2 v8.x for Linux, UNIX, Windows and higher
  • DB2 v9.1 for z/OS and higher
  • DB2 UDB v8.1 for z/OS
  • DB2 i 6.1 and higher
  • DB2 for i 5/OS V5R4 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC DB2 Driver
Version 5.1.4

Database Support
  • DB2 V8.x for Linux, UNIX, Windows and higher
  • DB2 V8.1 for z/OS and higher
  • DB2 UDB V8.1 for z/OS
  • DB2 i 6.1 and higher
  • DB2 for i 5/OS V5R4 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher

ADO.NET

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Machine must have .NET Framework 2.0 SP1 or higher with the .NET Framework Redistributable Version 2.0 or higher installed
  • The data providers connect to the following database on all platforms supported by the database vendor, unless otherwise noted. Both 32-bit and 64-bit versions are supported. In addition, all editions and service packs/fix packs of the database version are supported.
    • .NET Framework Versions 2.0, 3.0, 3.5, 4.1.0 and 4.5
    • Visual Studio 2008, 2010, 2012, 2013 and Lightswitch 2012
Database Support
  • DB2 V10.0, 10.1, 10.5 for Linux, UNIX, Windows using DRDA
  • DB2 V9.1, V9.5, V9.7 for Linux, UNIX, Windows
  • DB2 V8.x for Linux, UNIX, Windows
  • DB2 UDB V7.x for Linux, UNIX, Windows
  • DB2 V10.1 for z/OS
  • DB2 V9.1 for z/OS
  • DB2 UDB V8.1 for z/OS
  • DB2 UDB V7R1, V7R2 for i
  • DB2 UDB V6R1 for i
  • DB2 UDB V5R1, V5R2, V5R3, V5R4.1 for i

ADO.NET Entity Framework

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • DB2 ADO.NET Entity Framework requires .NET Framework 4.5 and later versions
  • DB2 ADO.NET Entity Framework supports features of Entity Framework 6.0
Database Support
  • DB2 UDB V7R1, V7R2 for i
  • DB2 UDB V6R1 for i
Programming Support
  • Applications Targeting .NET Framework 4.5
  • Database First, Model First, Code First, DBContext, Code First Migrations, Enumerated Types, Table Valued Functions, Code-Based Configuration (EF 6.0), Multiple Context Support, Connection Resiliency, Code First Map DML Operations To Stored Procedures

DataDirect Connect for ADO.NET Entity Framework data providers version 4.2.0 have been certified for running on the .NET Framework Versions 2.0 SP1 or higher, 3.0 SP1, 4.0, 4.5 and 5.0



dBase

ODBC

Progress DataDirect Connect for ODBC dBase Driver
Version 7.1.6

(32-bit drivers are available for all supported databases and platforms.)

Database Support
  • dBase IV and higher
Operating System Support
  • AIX (32-bit)
    • AIX, version 5.3 and higher
  • HP (32-bit)
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements


Force.com

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Salesforce Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Salesforce API
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i Version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), Version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 5 or higher

JDBC

Progress DataDirect Connect XE for JDBC Salesforce Driver
Version 5.1.4

Supported Versions
  • Salesforce API
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


FoxPro

ODBC

Progress DataDirect Connect for ODBC dBase Driver
Version 7.1.6

(32-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • FoxPro 6.0 and higher (with 3.0 functionality only)
  • FoxPro 2.5 and higher
Operating System Support
  • AIX (32-bit)
    • AIX, version 5.3 and higher
  • HP (32-bit)
    • HP-UX PA-RISC, version 11 and higher
  • Linux x86 (32-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements


Greenplum

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Greenplum Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Greenplum 3.3 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect XE for JDBC Greenplum Driver
Version 5.1.4

Database Support
  • Greenplum 3.2 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Informix

ODBC

Progress DataDirect Connect and Connect64 for ODBC Informix Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Informix Dynamic Server 9.2 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

The Progress DataDirect Connect for ODBC Informix Driver
Version 7.1.6

(32-bit drivers are available for all supported databases and platforms.)

Database Support
  • Informix Dynamic Server 9.2 and higher
Operating System Support
  • AIX (32-bit)
    • AIX, version 5.3 and higher
  • HP (32-bit)
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Solaris (32-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • I-Connect 2.2 or higher or Informix Client SDK 2.2 or higher

JDBC

Progress DataDirect Connect for JDBC Informix Driver
Version 5.1.4

Database Support
  • Informix Dynamic Server 9.2 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Microsoft SQL Server

ODBC

Progress DataDirect Connect and Connect64 for ODBC SQL Server Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Microsoft SQL Server 2000 and higher
  • Microsoft SQL Server 2000 Desktop Engine (MSDE 2000)
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

Progress DataDirect Connect and Connect64 for ODBC SQL Server Legacy Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Microsoft SQL Server 2000 and higher
  • Microsoft SQL Server 2000 Desktop Engine (MSDE 2000)
  • Microsoft SQL Server 7.0
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC SQL Server Driver
Version 5.1.4

Database Support
  • Microsoft SQL Server 2000 and higher
  • Microsoft SQL Server 2000 Desktop Engine (MSDE 2000)
  • Microsoft SQL Server 7.0
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher

ADO.NET

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Machine must have .NET Framework 2.0 or higher with the .NET Framework Redistributable Version 2.0 or higher installed
  • The data providers connect to the following database on all platforms supported by the database vendor, unless otherwise noted. Both 32-bit and 64-bit versions are supported. In addition, all editions and service packs/fix packs of the database version are supported.
    • .NET Framework Versions 2.0, 3.0, 3.5, 4.1.0 and 4.5
    • Visual Studio 2008, 2010, 2012, 2013 and Lightswitch 2012
Database Support
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008
  • Microsoft SQL Server 2005
  • Microsoft SQL Server 2000 Desktop Engine (MSDE 2000)
  • Microsoft SQL Server 2000


Microsoft Windows Azure SQL Database

ODBC

Progress DataDirect Connect and Connect64 for ODBC SQL Server Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Microsoft Windows Azure SQL Database Version 11.0 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC SQL Server Driver
Version 5.1.4

Database Support
  • Microsoft Windows Azure SQL Database Version 11.0 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


MongoDB

ODBC

Progress DataDirect for ODBC for MongoDB Driver
Version 8.0.0

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • MongoDB 2.2 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), 11i version 2.0 (B.11.23) and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 6 or higher

JDBC

Progress DataDirect for JDBC for MongoDB Driver
Version 6.0.0

Database Support
  • MongoDB 2.2 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 6 or higher


MySQL

ODBC

Progress DataDirect Connect and Connect64 for ODBC MySQL Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • MySQL Enterprise Edition 5.0 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC MySQL Driver
Version 5.1.4

Database Support
  • MySQL Enterprise Edition 5.0 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Oracle

ODBC

Progress DataDirect Connect and Connect64 for ODBC Oracle Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Oracle 12c R1 (12.1) and higher
  • Oracle 11g R1 (11.1) and higher
  • Oracle 10g R1 (10.1) and higher
  • Oracle 9i R1 (9.0.1) and higher
  • Oracle 8i R3 (8.1.7) and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86, version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements


Progress DataDirect Connect and Connect64 Oracle Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Oracle 12c R1 (12.1) and higher
  • Oracle 11g R1 (11.1) and higher
  • Oracle 10g R1 (10.1) and higher
  • Oracle 9i R1 (9.0.1) and higher
  • Oracle 8i R3 (8.1.7) and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i, version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher, for:
      • Oracle 12c and R1 (12.1) and higher
      • Oracle 10g R1 (10.1) and higher
    • Oracle Linux x86, version 4.0 and higher, for
      • Oracle 12c and R1 (12.1) and higher
      • Oracle 10g R1 (10.1) and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher, for
      • Oracle 12c and R1 (12.1) and higher
      • Oracle 10g R1 (10.1) and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Oracle Net Client for 9.2 or higher

JDBC

Progress DataDirect Connect for JDBC Oracle Driver
Version 5.1.4

Database Support
  • Oracle 12c R1 (12.1) and higher
  • Oracle 11g R1 (11.1) and higher
  • Oracle 10g R1 (10.1) and higher
  • Oracle 9i R1 (9.0.1) and higher
  • Oracle 8i R3 (8.1.7) and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher

ADO.NET

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Machine must have .NET Framework 2.0 or higher with the .NET Framework Redistributable Version 2.0 or higher installed
  • The data providers connect to the following database on all platforms supported by the database vendor, unless otherwise noted. Both 32-bit and 64-bit versions are supported. In addition, all editions and service packs/fix packs of the database version are supported.
    • .NET Framework Versions 2.0, 3.0, 3.5, 4.1.0 and 4.5
    • Visual Studio 2008, 2010, 2012, 2013 and Lightswitch 2012
Database Support
  • Oracle 12c
  • Oracle 11g R1, R2 (11.1, 11.2)
  • Oracle 10g R1, R2 (10.1, 10.2)
  • Oracle 9i R1, R2 (9.0.1, 9.2)
  • Oracle 8i R2, R3 (8.1.6, 8.1.7)

ADO.NET Entity Framework

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Oracle ADO.NET Entity Framework requires .NET Framework 4.5 and later versions
  • Oracle ADO.NET Entity Framework supports features of Entity Framework 6.0
Database Support
  • Oracle 12c
  • Oracle 11g R1, R2 (11.1, 11.2)
  • Oracle 10g R1, R2 (10.1, 10.2)
  • Oracle 9i R1, R2 (9.0.1, 9.2)
Programming Support
  • Applications Targeting .NET Framework 4.5
  • Database First, Model First, Code First, DBContext, Code First Migrations, Enumerated Types, Table Valued Functions, Code-Based Configuration (EF 6.0), Multiple Context Support, Connection Resiliency, Code First Map DML Operations To Stored Procedures, Configurable Migrations History Table

DataDirect Connect for ADO.NET Entity Framework data providers version 4.2.0 have been certified for running on the .NET Framework Versions 2.0 SP1 or higher, 3.0 SP1, 4.0, 4.5, and 5.0



Oracle Service Cloud

ODBC

Progress DataDirect for ODBC for Oracle Service Cloud Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Supported Versions
  • Oracle RightNow CX API 1.2 against sites with February 2014 version or later
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86, version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 5 or higher

JDBC

Progress DataDirect for JDBC for Oracle Service Cloud Driver
Version 5.1.4

Supported Versions
  • Oracle RightNow CX API 1.2 against sites with February 2014 version or later
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Pervasive.SQL (Btrieve)

ODBC

Progress DataDirect Connect for ODBC Btrieve Driver
Version 7.1.6

(32-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Pervasive.SQL 7.0 and higher
  • Btrieve 6.15
Operating System Support
  • Windows (32-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Pervasive Client (for Pervasive databases)
  • BDK (for Btrieve 6.x)


Pivotal HAWQ

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Greenplum Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Pivotal HAWQ 1.1 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86, version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect XE for JDBC Greenplum Driver
Version 5.1.4

Database Support
  • Pivotal HAWQ 1.1 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


PostgreSQL

ODBC

Progress DataDirect Connect and Connect64 for ODBC PostgreSQL Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • PostgreSQL 8.2 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86, version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC PostgreSQL Driver
Version 5.1.4

Supported Versions
  • PostgreSQL 8.2 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Progress OpenEdge

ODBC

Progress DataDirect Connect and Connect64 for ODBC Progress OpenEdge Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Progress OpenEdge 10.1.x and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC Progress OpenEdge Driver
Version 5.1.4

Supported Versions
  • Progress OpenEdge 10.1.x and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


Salesforce

ODBC

Progress DataDirect Connect XE and Connect64 XE for ODBC Salesforce Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • Salesforce API
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF (32- and 64-bit), 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86, version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • Java SE 5 or higher

JDBC

Progress DataDirect Connect XE for JDBC Salesforce Driver
Version 5.1.4

Supported Versions
  • Salesforce API
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher


SAP Adaptive Server Enterprise

ODBC

Progress DataDirect Connect and Connect64 for ODBC Sybase Wire Protocol Driver
Version 7.1.6

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Database Support
  • SAP Adaptive Server Enterprise 16.0 and higher
  • Sybase Adaptive Server Enterprise 11.9 and higher
Operating System Support
  • AIX (32- and 64-bit)
    • AIX, version 5.3 and higher
  • HP
    • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
    • HP-UX PA-RISC (32-bit only), version 11 and higher
  • Linux x86 (32- and 64-bit for AMD and Intel processors. 64-bit for Itanium II.)
    • CentOS Linux x86, version 4.0 and higher
    • Oracle Linux x86, version 4.0 and higher
    • Red Hat Enterprise Linux x86, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x86, version 10 and higher
  • Linux on System Z (64-bit only)
    • CentOS Linux x64, version 4.0 and higher
    • Oracle Linux x64, version 4.0 and higher
    • Red Hat Enterprise Linux x64, version 4.0 and higher
    • SUSE Linux Enterprise Server Linux x64, version 10 and higher
  • Solaris (32- and 64-bit)
    • Solaris x86 version 10 (Solaris 5.10) and higher
    • Solaris on SPARC, version 8 (Solaris 5.8) and higher
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
Driver/Client Software Requirements
  • No Requirements

JDBC

Progress DataDirect Connect for JDBC Sybase Driver
Version 5.1.4

Database Support
  • SAP Adaptive Server Enterprise 16.0 and higher
  • Sybase Adaptive Server Enterprise 11.5 and higher
Platform Support
  • 32- and 64-bit platforms
Software Requirements
  • Java SE 5 or higher

ADO.NET

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Machine must have .NET Framework 2.0 SP1 or higher with the .NET Framework Redistributable Version 2.0 or higher installed
  • The data providers connect to the following database on all platforms supported by the database vendor, unless otherwise noted. Both 32-bit and 64-bit versions are supported. In addition, all editions and service packs/fix packs of the database version are supported.
    • .NET Framework Versions 2.0, 3.0, 3.5, 4.1.0 and 4.5
    • Visual Studio 2008, 2010, 2012, 2013 and Lightswitch 2012
Database Support
  • Sybase Adaptive Server 15.0, 15.5, 15.7
  • Sybase Adaptive Server 12.0, 12.5.x
  • Sybase Adaptive Server 11.5, 11.9

ADO.NET Entity Framework

Progress DataDirect Connect for ADO.Net
Version 4.2.0

  • Sybase ADO.NET Entity Framework requires .NET Framework 3.5 SP1 and later versions
  • Sybase ADO.NET Entity Framework supports features of Entity Framework 3.5
Database Support
  • Sybase Adaptive Server 15.7
  • Sybase Adaptive Server 15.5
  • Sybase Adaptive Server Enterprise 15.0.3 or later versions
Programming Support
  • Applications Targeting .NET Framework 3.5, 4.0, 4.5
  • Database First, DBContext

DataDirect Connect for ADO.NET Entity Framework data providers version 4.2.0 have been certified for running on the .NET Framework Versions 2.0 SP1, 3.0 SP1, 4.0, 4.5 and 5.0



SAP HANA

ODBC

Progress DataDirect for ODBC for SAP HANA Wire Protocol Driver
Preview Version

(32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

Supported Versions
  • SAP HANA, version 1.0 and higher
Operating System Support
  • Windows (32- and 64-bit)
    • Windows (x86), version 7 and higher
    • Windows Server (x86), version 2003 and higher
    • Windows Vista (x86)
    • Windows XP Professional (x86), SP2 or higher
  • Driver/Client Software Requirements
    • No Requirements


    SAP Sybase IQ

    ODBC

    Progress DataDirect Connect XE and Connect64 XE for ODBC Sybase IQ Wire Protocol Driver
    Version 7.1.6

    (32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

    Database Support
    • SAP IQ 16.0 and higher
    • Sybase IQ 15.0 and higher
    Operating System Support
    • AIX (32- and 64-bit)
      • AIX, version 5.3 and higher
    • HP
      • HP-UX IPF, 11i version 2.0 (B.11.23) and higher
      • HP-UX PA-RISC (32-bit only), version 11 and higher
    • Linux x86 (32- and 64-bit for AMD and Intel processors)
      • CentOS Linux x86, version 4.0 and higher
      • Oracle Linux x86, version 4.0 and higher
      • Red Hat Enterprise Linux x86, version 4.0 and higher
      • SUSE Linux Enterprise Server Linux x86, version 10 and higher
    • Solaris (32- and 64-bit)
      • Solaris x86, version 10 (Solaris 5.10) and higher
      • Solaris on SPARC, version 8 (Solaris 5.8) and higher
    • Windows (32- and 64-bit)
      • Windows (x86), version 7 and higher
      • Windows Server (x86), version 2003 and higher
      • Windows Vista (x86)
      • Windows XP Professional (x86), SP2 or higher
    Driver/Client Software Requirements
    • No Requirements


    Teradata

    ODBC

    Progress DataDirect Connect XE and Connect64 XE for ODBC Driver for Teradata
    Version 7.1.6

    (32- and 64-bit drivers are available for all supported databases and platforms unless otherwise noted.)

    Database Support
    • Teradata 12.0 and higher
    • Teradata V2R6.0 and higher
    Operating System Support
    • AIX (32- and 64-bit)
      • AIX, version 5.3 and higher
    • HP
      • HP-UX IPF (64-bit only), 11i version 2.0 (B.11.23) and higher
      • HP-UX PA-RISC (32-bit only), version 11 and higher
    • Linux x86 (32- and 64-bit for AMD and Intel processors)
      • CentOS Linux x86, version 4.0 and higher
      • Oracle Linux x86, version 4.0 and higher
      • Red Hat Enterprise Linux x86, version 4.0 and higher
      • SUSE Linux Enterprise Server Linux x86, version 10 and higher
    • Solaris (32- and 64-bit)
      • Solaris x86 (32-bit only), version 10 (Solaris 5.10) and higher
      • Solaris on SPARC, version 8 (Solaris 5.8) and higher
    • Windows (32- and 64-bit)
      • Windows (x86), version 7 and higher, for:
        • Teradata 13.0 and higher
      • Windows Server (x86), version 2003 and higher:
        • Teradata 13.0 and higher
        • Teradata 12.0 on Windows 2008 and 2003 only
        • Teradata V2R6.0 and higher on Windows Server 2003 only
      • Windows Vista (x86) for:
        • Teradata 13.0 and higher
      • Windows XP Professional (x86), SP2 or higher
        • Teradata 13.0 and higher
    Driver/Client Software Requirements
    Database Client Software
    Teradata 12.0 and higher TTU CLIv2, TGSS, and ICU client software that corresponds with the database version
    Teradata V2R6.0 and higher TTU 8.2 or higher CLIv2, TGSS, and ICU client software


    Text

    ODBC

    Progress DataDirect Connect for ODBC Text Driver
    Version 7.1.6

    (32- bit drivers are available for all supported databases and platforms unless otherwise noted.)

    Format Support
    • ASCII text files
    Operating System Support
    • AIX (32-bit)
      • AIX, version 5.3 and higher
    • HP (32-bit)
      • HP-UX PA-RISC, version 11 and higher
    • Linux x86 (32-bit for AMD and Intel processors)
      • CentOS Linux x86, version 4.0 and higher
      • Oracle Linux x86, version 4.0 and higher
      • Red Hat Enterprise Linux x86, version 4.0 and higher
      • SUSE Linux Enterprise Server Linux x86, version 10 and higher
    • Solaris (32-bit)
      • Solaris on SPARC, version 8 (Solaris 5.8) and higher
    • Windows (32-bit)
      • Windows (x86), version 7 and higher
      • Windows Server (x86), version 2003 and higher
      • Windows Vista (x86)
      • Windows XP Professional (x86), SP2 or higher
    Driver/Client Software Requirements
    • No Requirements


    XML

    ODBC

    Progress DataDirect Connect for ODBC XML Driver
    Version 7.1.6

    (32-bit drivers are available for all supported databases and platforms.)

    Format Support
    • XML Documents (tabular- and hierarchical-formatted)
    Operating System Support
    • Windows (32-bit)
      • Windows (x86), version 7 and higher
      • Windows Server (x86), version 2003 and higher
      • Windows Vista (x86)
      • Windows XP Professional (x86), SP2 or higher
    Driver/Client Software Requirements
    • Internet Explorer 5 or higher