DataDirect Cloud Database Support

Data Store Product Version
NOTE: DataDirect Cloud supports connecting to the following database versions on all platforms supported by the database vendor, unless otherwise noted. Both 32-bit and 64-bit versions are supported. In addition, all editions and service packs/fix packs for each database version are supported.
Apache Hive™ (HiveServer1 and HiveServer2)
see table for versions supported
IBM DB2 DB2 V10.1, V10.5 for Linux, UNIX, Windows
DB2 V9.1, V9.5, V9.7,
V9.8 for Linux, UNIX, Windows
DB2 V8.x for Linux, UNIX, Windows
DB2 V11 for z/OS
DB2 V10 for z/OS
DB2 V9.1 for z/OS
DB2 UDB V8.1 for z/OS
DB2 i 7.1 (DB2 UDB V7R1 for I)
DB2 i 6.1 (DB2 UDB V6R1 for I)
DB2 for i 5/OS V5R4 (DB2 UDB V5R4 for I)
Oracle Eloqua API 2.0
FinancialForce.com (See Salesforce) *
Force.com (See Salesforce) *
Google Analytics
Greenplum Greenplum 4, 4.1, 4.2
Greenplum 3.3
HubSpot
Informix Dynamic Server Informix 12.1
Informix Dynamic Server 11.0, 11.5, 11.7
Informix Dynamic Server 10.0
Informix Dynamic Server 9.2, 9.3, 9.4
Marketo API 2.1, 2.2
Microsoft Dynamics CRM Online  
Microsoft Dynamics CRM (Kerberos authentication only) 2011 Rollup 16, 2013, 2015
Microsoft SQL Server Microsoft Azure SQL Database 11.0
Microsoft SQL Server 2014
Microsoft SQL Server 2012
Microsoft SQL Server 2008 R1, R2
Microsoft SQL Server 2005
Microsoft SQL Server 2000 Desktop Engine (MSDE)
Microsoft SQL Server 2000
MySQL MySQL Enterprise Edition 5.0, 5.1, 5.5, 5.6
Oracle Oracle 12c R1 (12.1)
Oracle 11g R1, R2 (11.1, 11.2)
Oracle 10g R1, R2 (10.1, 10.2)
Oracle 9i R1, R2 (9.0.1, 9.2)
Oracle 8i R3 (8.1.7)
Oracle Service Cloud

Oracle RightNow CX API version 1.2 against sites whose version is one of the following:

  • May 2015
  • February 2015
  • November 2014
  • August 2014
  • May 2014
  • February 2014
PostgreSQL PostgreSQL 9.0, 9.1, 9.2
PostgreSQL 8.2, 8.3, 8.4
Progress OpenEdge 11.0, 11.1, 11.2, 11.3, 11.4
Progress OpenEdge 10.1A, 10.1B, 10.1C, 10.2A, 10.2B
Progress Rollbase 2.0 and higher
Salesforce API Version 34
ServiceMax (See Salesforce) *
SugarCRM 7.1.6 and higher
Sybase Adaptive Server Sybase Adaptive Server 15.0, 15.5, 15.7
Sybase Adaptive Server 12.0, 12.5, 12.5.x
Sybase Adaptive Server 11.9
Veeva CRM (See Salesforce) *

Supported Apache Hive Versions and Distribution Versions

Distribution Version Apache Hive Version
Amazon Elastic MapReduce (Amazon EMR) N/A Hive 0.8.x
Hive 0.9.x
Hive 0.11x
Apache Hadoop Hive N/A Hive 0.8.x
Hive 0.9.x
Hive 0.10.x
Hive 0.11.x
Hive 0.12.x
Cloudera's Distribution Including Apache Hadoop (CDH) CDH 4.0.x
CDH 4.1.x
CDH 4.2.x
CDH 4.3.x
CDH 4.4.x
CDH 4.5.x
Hive 0.8.x
Hive 0.9.x
Hive 0.10.x
Hive 0.11.x
Hive 0.12.x
Hortonworks Distribution for Apache Hadoop HDP 1.3
HDP 2.0
Hive 0.11.x
Hive 0.12.x
MapR Distribution for Apache Hadoop MapR 2.0 Hive 0.9.x