XQuery Support Matrix



Progress DataDirect XQuery™

J2SE 1.4, J2SE 5, Java SE 6 (32- and 64-bit)
Database DataDirect XQuery®
NOTE: DataDirect XQuery® supports connecting to the following database versions on all platforms supported by the database vendor, with exceptions noted. Support includes all service packs/fix packs for each listed database version and all editions of the database versions.
DB2
DB2 V9.5, V9.1 for Linux, UNIX, Windows 5.0
DB2 V8.x for Linux, UNIX, Windows 5.0
DB2 V10 for z/OS 5.0
DB2 V9.1 for z/OS 5.0
DB2 V8.1 for z/OS 5.0
DB2 for i 7.1 5.0
DB2 for i 6.1 5.0
DB2 for i5/OS V5R4 5.0
Informix Dynamic Server
Informix Dynamic Server 11.7, 11.5, 11.0 5.0
Informix Dynamic Server 10.0 5.0
Informix Dynamic Server 9.4, 9.3, 9.2 5.0
Microsoft SQL Server
Microsoft SQL Server 2008 R1, R2 5.0
Microsoft SQL Server 2005 5.0
Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) 5.0
Microsoft SQL Server 2000 5.0
Microsoft SQL Server 7.0 5.0
MySQL
MySQL Enterprise Edition 5.1, 5.0 5.0
Oracle
Oracle 11g R2, R1 (11.2, 11.1) 5.0
Oracle 10g R2, R1 (10.2, 10.1) 5.0
Oracle9i R2, R1 (9.2.0, 9.0.1) 5.0
PostgreSQL
PostgreSQL 8.1, 8.2 * 5.0
Sybase Adaptive Server
Sybase Adaptive Server Enterprise 12.5.x and 15.0 5.0
* Requires the PostgreSQL JDBC driver.